Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 21, 2019 - 23:00 PDT
Scheduled
We will be upgrading to a new major release of our SureTel platform. We do expect some downtime during this window of two to three - 1 Minute or less outages.
We will be sending out an email shortly with the full release notes but here are a few new great features to look forward to. * Advanced extensions (Route calls dynamically to any device) * Auto login/logout of Queues * Chrome Call Controller out of Beta * Enhanced SMS with Queues * Extensive Call Queue Reporting Upgrade * Brand new mobile apps with more iOS and Android version support * Many More Security and Reliability Fixes
Posted Oct 21, 2019 - 09:39 PDT
This scheduled maintenance affected: SureTel - Web Portal and SureTel - SIP.