E911 Unavailable
Incident Report for SureTel
Resolved
E911 service has been restored. We will continue to monitor and notify of any future issue. Once again we apologize for any inconvenience.
Posted Dec 16, 2017 - 06:38 PST
Monitoring
We received a message from our E911 provider that their network is down. Currently our system will be unable to process 911 calls. Please use a cell phone in case of emergency. They currently have no ETA but we will update as soon as possible. We appologize for the inconvenience.
Posted Dec 15, 2017 - 04:21 PST