Call Quality Degredation
Incident Report for SureTel
Resolved
We are seeing services fully restored since last night. We are continuing to monitor the system for any further issues and keeping close contact with our downstream carrier.
Posted Nov 19, 2021 - 08:05 PST
Update
We are continuing to experience degraded call quality. We are working with our downstream carrier to get this resolved as soon as possible and reviewing options for better mitigating this with our carrier in the future.
Posted Nov 18, 2021 - 08:47 PST
Identified
We have been notified that our downstream carrier has received a renewed DDOS attack. The recent updates are mitigating most of the attack, however you may experience reduced call quality or possibly calls being dropped.
Posted Nov 17, 2021 - 08:35 PST
This incident affected: SureTel - SIP.