System Outage
Incident Report for SureTel
Resolved
This incident has been resolved.
Posted Oct 02, 2023 - 05:14 PDT
Monitoring
We believe everything is resolved now. We are continuing to monitor for further issues. We will send an after action report soon.

We are truly sorry for this outage and any issues it may have caused you. This situation does not hold up to the level of performance that we expect from our systems and vendors. We will be providing more information soon as well as details on service credits that will be following.
Posted Sep 29, 2023 - 12:46 PDT
Update
Services are slowly coming back up again. Calls are flowing again, however there are some additional call services that are not functional at the moment, including the IVR service, in the background but calls are now flowing.

We are continuing to work on fully restoring all services and will provide regular updates as we can.
Posted Sep 29, 2023 - 11:16 PDT
Update
We are working closely with Google Cloud Support to resolve this service issue and believe a fix is nearly ready. We will provide another update within the hour.
Posted Sep 29, 2023 - 10:29 PDT
Update
We have isolated the issue are working with Google cloud support to resolve as soon as possible.
Posted Sep 29, 2023 - 08:06 PDT
Identified
We have identified an issue with the server hosting platform not booting a critical service and are working to get the service running agian.
Posted Sep 29, 2023 - 06:27 PDT
Investigating
We are currently investigating the issue with a recent update that has caused phones and the web portal to be inaccessible.
Posted Sep 29, 2023 - 05:13 PDT
This incident affected: SureTel - Web Portal and SureTel - SIP.